Problems with iCloud in Writer 1.2.2

Critter's Avatar

Critter

26 May, 2012 04:15 AM

I just updated to 1.2.2 and my "iCloud" just shows everything in my ~/ directory. All my recent documents that were saved to iCloud, I have no access to. Even the ones that are displayed in the "recent" menu, are all disabled.

suggestions?

  1. 1 Posted by Critter on 26 May, 2012 04:20 AM

    Critter's Avatar

    Actually it looks like it's ~/Documents.

    I can open up recent iCloud documents that show when I right click the dock icon, but using the File menu up top shows everything disabled.

    ah.. well it seems that clicking "iCloud" in the open document dialogue, just hides the folder view that is visible when "on my Mac" is clicked...

  2. 2 Posted by Critter on 26 May, 2012 04:26 AM

    Critter's Avatar

    I can create a new file, but no longer have the option of saving to iCloud. I have checked in system preferences, and I /am/ currently logged into iCloud.

    I am on 10.8 DP3. The previous version worked fine. I have had no problems until I updated to 1.2.2 today.

  3. 3 Posted by Anton Sotkov on 26 May, 2012 07:29 AM

    Anton Sotkov's Avatar

    Same problem here. 1.2.2, 10.8 DP3 with latest updates installed.

    Mountain Lion's “Open File” dialog displays TextEdit's iCloud documents folder unless it's empty, then ~/Desktop unless it's empty, then ~/Documents, and when I create a new document I can't save it to iCloud at all — the option doesn't exist in “Save File” dialog.

    Also, it looks like the File > iCloud menu works, it's very inconvenient, since Mountain Lion pop up its “Open File” dialog (which I've grown used to).

    Thanks for looking into the issue!

  4. 4 Posted by Roger Scrafford on 27 May, 2012 03:42 PM

    Roger Scrafford's Avatar

    I can't perform the update to 1.2.2 because the App store tells me to sign in via an Apple ID that is not my own ([email blocked] -- see image). I am not offered an opportunity to download using my actual Apple ID.
    This problem happens only when I'm trying to update iA Writer to 1.2.2. No other app purchase or update triggers this App store response.

  5. 5 Posted by Anton Sotkov on 27 May, 2012 04:12 PM

    Anton Sotkov's Avatar

    Roger, I think this may happen if a receipt for this Apple ID exists in the app bundle. Where did you get that copy of the app? To fix this error, move current version of Writer to Trash, and simply install 1.2.2 instead of updating.

  6. 6 Posted by Oli Studholme on 28 May, 2012 04:38 AM

    Oli Studholme's Avatar

    I’m sorry to hear you’re having problems with the 1.2.2 update. We’ll investigate these issues, but unfortunately we can not promise Writer will work on 10.8 until it is released. Thank you for your understanding on this.

    @Roger — iA Writer 1.2.2 should appear in Updates, and once you’ve updated in Purchases. If you’ve updated but are still getting 1.2.1, please delete iA Writer.app, sign into the App Store using your Apple ID, and reinstall from the App Store.

    Happy writing!

  7. 7 Posted by Critter on 28 May, 2012 03:28 PM

    Critter's Avatar

    I understand that you cannot guarantee it working in 10.8. Is there any chance you can make the previous version available for a quick download?

  8. 8 Posted by Shaun on 28 May, 2012 06:25 PM

    Shaun's Avatar

    I too cannot open any documents that I had in iCloud in the previous version. It says that I need to configure iCloud, but I already have. I am not running 10.8 ,but 10.7.4.

  9. 9 Posted by Oli Studholme on 29 May, 2012 10:58 AM

    Oli Studholme's Avatar

    We’re trying to find the bug now, but we haven’t been able to replicate it yet. To help, if you have a problem using iCloud in Writer 1.2.2, please mention:

    • the version of OS X you’re using
    • what happens when you try to use iCloud
    • whether it’s repeatable or only happens occasionally

    If you’re experiencing crashes trying to use iCloud, we’d really appreciate it if you could attach a crash log. You can find this in the Finder using Go > Go to Folder… and entering ~/Library/Logs/DiagnosticReports. Alternatively you can use the utility Console.app: look for the crash log under Files > ~/Library/Logs > CrashReporter, click on the most recent Writer crash log, and choose File > Save a Copy As…

    Unfortunately we can’t provide the previous version for download. I’m sorry we haven’t worked this out yet, but we will try to solve it as soon as we can.

    Happy writing!

  10. 10 Posted by luhovoy on 29 May, 2012 11:18 AM

    luhovoy's Avatar

    after reinstalling iCloud works

  11. 11 Posted by Critter on 29 May, 2012 02:31 PM

    Critter's Avatar

    No worries mate. I appreciate you looking into it..

    I am on:
    10.8 DP3 (latest update)

    I have uninstalled iAWriter (including plist), and reinstalled, but no luck..
    attached is what I see.

    If I click on "on my mac" it brings up folder selection... clicking iCloud just hides the folder selection..

  12. 12 Posted by Anton Sotkov on 29 May, 2012 08:33 PM

    Anton Sotkov's Avatar

    I have the same issues as @Critter. The issues are consistently reproducible, and nothing fixes them (I've tried reinstalling Writer, removing all of the configuration files, etc).

  13. 13 Posted by Shaun on 30 May, 2012 04:46 AM

    Shaun's Avatar

    I am using 10.7.4 on my Mac and I cannot even access iCloud on iAwriter with this version. I could in the previous version. When I go to my iCloud settings, it shows that I have iA Writer documents in iCloud, but they are not accessible through iA Writer.

  14. 14 Posted by luhovoy on 30 May, 2012 04:49 AM

    luhovoy's Avatar

    i had exactly the same trouble and solved it without re-installing by:
    I run the last beta 1.2.2f2 once again, closed it and could open the final version 1.2.2 without the bug appearing.

  15. 15 Posted by Shaun on 30 May, 2012 04:51 AM

    Shaun's Avatar

    This happened in the final version of 1.2.2 for me, and I uninstalled and and reinstalled and the same problem.

  16. 16 Posted by David on 31 May, 2012 05:01 PM

    David's Avatar

    I'm also experiencing the exact same scenario as Critter mentions above. I am on 10.8 DP3 - just updated to the latest version of iA Writer (1.2.2) and I can't access my previous files in iCloud that I created in iA Writer before.

    -David

  17. 17 Posted by Jesper van Haar... on 04 Jun, 2012 05:03 PM

    Jesper van Haaren's Avatar

    Same problem here. OS X 10.8 DP3 latest version. iCloud shows my local files. iCloud option not available when saving. Move document to iCloud in menu bar works fine. Opening files from iCloud in the menu bar works fine as well. No crashes here. Other apps that use iCloud, like Coda 2, don't have this problem.

  18. 18 Posted by Oli Studholme on 05 Jun, 2012 01:43 PM

    Oli Studholme's Avatar

    I’m sorry for the ongoing problems you’re experiencing with iCloud in Writer 1.2.2. We haven’t resolved the issue with Mountain Lion 10.8 DP3 yet, but we were able to replicate and solve iCloud showing the content of ~/Documents in Mac OS X 10.7.4:

    1. Delete iA Writer + preferences with AppCleaner
    2. Disable MobileMe
    3. Restart computer
    4. Install iA Writer from the App Store (Purchases section)

    I’ve attached a screenshot of the files AppCleaner deletes.

    For anyone having problems with iCloud in Writer 1.2.2 on Lion, please try this and let me know if it fixes the issue for you. For people on Mountain Lion I’m sorry we don’t have a solution for you yet, but we’ll let you know as soon as we can.

    Happy writing!

  19. 19 Posted by Oli Studholme on 13 Jun, 2012 03:17 AM

    Oli Studholme's Avatar

    We’ve tested Writer 1.2.2 with iCloud in Mountain Lion DP 4 and it seems to be working as expected. If you update to DP 4, please let me know if this problem continues or if Writer+iCloud works for you. Also, is anyone on Lion or Snow Leopard who has tried the above suggestions still having problems? If so please let me know.

    Happy writing!

  20. 20 Posted by Jesper van Haar... on 13 Jun, 2012 09:01 AM

    Jesper van Haaren's Avatar

    Hi Oli,

    Running DP 4 and everything is back to normal. Thanks for the effort!
    I have a question about the iOS apps. Can I email you about this?

  21. 21 Posted by Oli Studholme on 13 Jun, 2012 09:36 AM

    Oli Studholme's Avatar

    Happy to hear it. You can contact us at writer atmark informationarchitects.jp or start a private support discussion here.

    Happy writing!

  22. 22 Posted by Critter on 13 Jun, 2012 03:46 PM

    Critter's Avatar

    hmmm. I've upgraded to DP4, but I still seem to have the same issues as with DP3.

    I'll delete all my preferences, and give it a go again.

  23. 23 Posted by Critter on 16 Jun, 2012 02:01 PM

    Critter's Avatar

    well that sucked.

    ran into a bit of a snafu. deleted app. turned off iCloud. turned it back on.. computer locked. had to hard reboot. BAM.

    grey screen of death at start up.. some horrible 20 second loop. Took computer to apple. they reinstalled Lion. I reinstalled DP4.

    iA Writer works as it should now.

    TL;DR: Ate ice cream and drank coffee during reboot. iA Writer works fine now. Thanks

  24. 24 Posted by Oli Studholme on 18 Jun, 2012 07:11 AM

    Oli Studholme's Avatar

    @Critter — well, the ice cream and coffee part sounds good, at least :/ I’m sorry to hear about your problems, but I’m glad everything is working as expected for you now.

    Happy writing!

  25. Oli Studholme closed this discussion on 05 Jul, 2012 05:28 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac